Contribute

Maintaining Web Pages with Adobe Contribute

Faculty Multimedia Development Lab

Hours: Monday-Friday, 9:00am-4:00pm
Location: 67 MacNider Hall
Phone: 6-3519

Outline

 

Getting Started

  1. Insert the CD and follow the prompts to install the software.
  2. Once the software is installed, open/start Contribute.
  3. To set up the site you will be making changes to click the Create Connection button.
    • Contribute connection key: you can skip this part by clicking next.
    • Web address (URL): type in the full address to your web site (IE - http://www.med.unc.edu/roadmap).
    • Connection: from the drop-down menu select FTP or SFTP.
    • Name of your FTP server: this will vary. Please check with OIS for this information.
    • FTP username & password: is your SOM user ID (the same login & password you use for SOM email).
    • Folder location: this will vary. Please check with an OIS staff member for this information.
    • User information: this is self explanatory.
    • Summary: if the information was entered correctly you should see a congratulations screen that says you can now use Contribute to edit your web site. Select the Done button to finish.

[top]

The Contribute workspace

The Contribute workspace has three main areas: the Contribute browser/editor, the toolbar, and the sidebar. You can expand, collapse, or resize the panels and the sidebar as needed.

workspace.gif

 

  1. Browser/Editor

    The main window in Contribute is used for browsing and editing. If you are not sure whether you are browsing or editing in Contribute, look at the toolbar. The toolbars are different when you are browsing and when you are editing a draft
  2. Toolbar

    When you are editing, the editor toolbar enables you to edit text or images, depending on the content you’ve selected.
  3. Sidebar

    • "Pages" panel - gives you access to all drafts you’re currently editing.
    • "How Do I..." panel - provides quick step-by-step instructions to help you complete some common Contribute tasks. Click any link in the panel to get more information on that task

[top]

Using Contribute

The Contribute editor works much as a word processor does. You can edit text, images, tables, and links on the page. The toolbar contains familiar editing buttons, plus buttons for saving your edits until later, canceling your edits, or publishing your edits to the website.

  1. Editing a Page

    Browse to the web page that you want to edit. You can do this by typing in the URL (web address) in the Address bar or, if your installation was properly configured your department’s web site should be listed under the Home Pages button. When you are viewing the page you wish to edit click on the Edit Page button to open the page in the Contribute editor. When you are finished editing your page click the Publish button and Contribute will replace the existing page on your web server with your edited version so that it is live on your website. You can click on the Cancel button any time during the editing process (before you publish) to discard your changes and exit the publishing process.

  2. Save for Later

    If you want to work on some changes but can’t complete them all at the same time you can save them by clicking on the Save for Later button. Contribute will save and list these changes under the Pages section of the sidebar. If your sidebar is not open select View > Sidebar or hit the F4 key. When you wish to continue your changes to a page that you saved simply double click on it’s listing under the Pages section of the sidebar.

  3. Creating a Link

    You can add a link to both text documents (ppt, doc, xlc, etc) and images. Simply select the image or highlight the appropriate text and click on the Link button.

    • Browse to Web Page: Use this to add a link to any other site. You must type in the complete address to include http://www...

    • E-mail Address: Use this to link to an email address.

    • File on My Computer: Use this to link to a file, such as a Word document, that is stored on your computer. When you publish the page Contribute will also upload the file(s) that you linked to.

  4. Undoing Mistakes

    As in most applications, you can undo individual mistakes as you make them. You can also redo an edit if you decide that you don’t want to undo it. You can also discard changes, after you publish your draft, by rolling back to a previous version of a page.

    • To undo an edit select Edit > Undo.

    • To redo an edit select Edit > Redo.

    • To roll back to a previous version of a page browse to that page. Then select File > Actions > Roll Back to Previous Version. The Roll Back Page dialog box appears. Select a previous version from the list and click the Roll Back button.

[top]

Working With Text

  1. Formatting Text

    You can use Macromedia Contribute to add and format text, much as you do with a basic word processor such as Microsoft Word. You can add text to a web page by typing text, copying and pasting text, or dragging text from another application or web page to your Contribute draft. Note: Contribute might preserve text formatting applied in the other application.

  2. Spell Check

    It’s a good idea to use the Check Spelling command to check the spelling in your draft after you add or edit text. To check and correct spelling select Format > Check Spelling.

  3. Adding Paragraph Spacing

    To add a paragraph return, place the insertion point at the end of a paragraph and press Enter (Windows) or Return (Macintosh). To add a line break, Select Insert > Line Break or press Shift+Enter (Windows) or Shift+Return (Macintosh).

  4. Creating Lists

    You can create numbered lists, bulleted lists, and definition lists in Contribute. You can also create sublists within your lists.

    • To create a list: place the insertion point in your draft where you want to add the list. Click the Numbered List or Bulleted List button in the text formatting toolbar or select Format > List > Numbered List (or Bulleted List). Type the first list item. Press Enter (Windows) or Return (Macintosh) to type another item, and repeat for each item. When you finish typing the list, press Enter or Return twice.

    • To create a list from existing text: select the text. Click the Numbered List or Bulleted List button in the text formatting toolbar or select select Format > List > Numbered List (or Bulleted List).

  5. Creating Sublists

    You can change the level of a numbered or bulleted list item to create a nested list. For example, you might have a bulleted list where one of the bullets has a sublist of bullets. The nested list does not have to be of the same type as the parent list. For instance, you can nest a bulleted list in a numbered list. You can have multiple nested lists within your list. To create a sublist place the insertion point at the end of the line within an existing list where you want to create the sublist. Click the Indent button in the text formatting toolbar or select Format > Indent. Contribute indents the number or bullet of the new line. If you want the sublist and parent list to be different types, click the Numbered List or Bulleted List button in the text formatting toolbar, as appropriate.

  6. Adding Style

    The Style pop-up menu in Contribute lists HTML heading and paragraph styles, plus user-defined Cascading Style Sheet (CSS) styles that you can apply to format your content. All styles in the list appear as they will appear when you apply them to text. To apply a style to text select the text you want to change. Select a style from the Style pop-up menu in the text formatting toolbar or select Format > Style, and then select a style from the pop-up menu.

  7. Special Characters

    You can add special characters, such as a copyright symbol (©) or a pound sign (#), to your page. Place the insertion point in your draft where you want the character to appear. Select Insert > Special Characters, and then select Other. In the Insert Other Character dialog box, click the character you want to insert, and then click OK.

  8. Find and Replace

    You can search the draft you’re editing for specific text. You can also search for and replace text in drafts. To find and/or replace text select Edit > Find. The Find and Replace dialog box appears which works similar to that of a word processor. 

[top]

Working With Images

  1. Format

    Images that you add to your page should be in one of the following web-ready formats: JPG or GIF. If the image you want to add is in another format, you can use an image-editing tool, such as Macromedia Fireworks or Adobe Photoshop, to convert the image to a web-ready format. If you need assistance with this the Multimedia Lab at 67 MacNider, is a facility where medical school faculty and staff can use scanners and graphics software. For more information visit http://www.med.unc.edu/ois/facilities/multimedialab.

  2. Add an Image

    There are three ways you can add an image to your web page: use the Insert menu or the Image button to add an image from your computer or website, drag an image from another source to your Contribute draft, or copy and paste an image from another source on your Contribute draft.

    • To add an image using the Insert menu or Image button: Place the insertion point in your draft where you want the image to appear and click the Image button in the toolbar or select Insert > Image. Browse to and select the image, and then click the Select or OK button.
    • Dragging images to a page: Reduce the size of the Contribute application window so you can also see the application that contains the image you plan to drag. In the other application, select the image. Drag the image to your Contribute draft where you want the image to appear. Tip: You can’t drag an image from a web browser if the image has a link attached to it. Save the image to your computer first, and then drag the image to your Contribute draft, or copy and paste the image.
    • Copying and pasting images: In the application that contains the image you want to copy, select the image. Select Edit > Copy. Place the insertion point in your Contribute draft where you want the image to appear. Select Edit > Paste.
  3. Move an Image

    You can either drag the image to a new location or select the image, and then copy (or cut) and paste the image in a new location.

  4. Aligning an Image

    You can change image alignment two ways: you can change the alignment of an image on the page (for example, where an image is in a table cell) or you can change how the image aligns with surrounding elements.

    • To change alignment of an image – select the image you want to realign. Click an alignment option in the image editing toolbar. Contribute aligns the image in the draft.
    • To change alignment of an image in relation to surrounding elements – select the image you want to realign. Double-click the image, and then select an option from the Alignment pop-up menu in the Image Properties dialog box or Right-click (Windows) or Control-click (Macintosh) the image, and then select an option from the Align pop-up menu. Contribute aligns the image in relation to surrounding elements, such as text.

[top]

Working With Tables

A table is a powerful tool for presenting tabular data. For example, you might add a table to a web page that lists all your staff in one column, with their contact information in another column. In Contribute, you can add text and images to table cells the same way that you add text and images to a page. After you create a table you can easily modify both its appearance and structure.

  1. Inserting a Table

    You can insert a table anywhere on a page, including within another table. To insert a table, place the insertion point in your draft where you want the table to appear. Then click the Table button in the toolbar or select Insert > Table or select Table > Insert > Table. The Insert Table dialog box appears.
  2. Insert Table Dialog Box
    • Table size: enter the number of rows and columns you need in your table.

    • Table width: Indicates how wide the table is. Select Default width if you want the width of the table columns to change as you add content. Select Specific width if you want a fixed table width. Enter a number, and use the pop-up menu to indicate whether the number represents a number of pixels or the percentage of the page the table will occupy.

    • Border thickness: Is the thickness of the border around the table. Enter 0 if you do not want a table border.

    • Cell padding: Indicates the amount of space, in pixels, between the edge of the table cell and the content of the cell. If you do not enter a value, Contribute sets cell padding to the default value, which is 1 pixel.

    • Cell spacing: Indicates the amount of space, in pixels, between each table cell. If you do not enter a value, Contribute sets cell spacing to the default value, which is 2 pixels.

    • Header: Click a button in the Header section to indicate whether you want a header; None indicates no header. Left indicates a header column. Top indicates a header row. Both indicates a header column and a header row.

  3. When Formatting Tables

    You can set properties for the entire table or for selected cells, rows, or columns in the table. To change the properties of a table, select it, and then click the Table button.

  4. Resizing Tables, Rows, and Columns

    You can resize an entire table or individual rows and columns. When you resize an entire table, all the cells in the table are resized proportionately.

[top]

Adding Rows and Columns To a Table

You can add a single row or column, or you can add multiple rows or columns at the same time.

  1. Add a Single Row

    • Place the insertion point in a table cell, or select an entire row.

    • Do one of the following:

      • Click the Insert Row Below button in the toolbar. A new row appears below the insertion point or selection.

      • Select Table > Insert > Row Above or Table > Insert > Row Below.

      • Right-click (Windows) or Control-click (Macintosh), and then select Insert Row Above or Insert Row Below.

  2. Add a Single Column

    • Place the insertion point in a table cell, or select an entire column.
    • Do one of the following:
      • Click the Insert Column to the Right button in the toolbar.
      • A new column appears to the right of the insertion point or selection.
      • Select Table > Insert > Column to the Left or Table > Insert > Column to the Right.
      • Right-click (Windows) or Control-click (Macintosh), and then select Insert Column to the Left or Insert Column to the Right.
  3. Add Multiple Rows or Columns

    • Place the insertion point in a table cell.
    • Do one of the following:
      • Select Table > Insert > Multiple Rows or Columns.
      • Right-click (Windows) or Control-click (Macintosh), and then select Insert Multiple Rows or Columns. The Insert Rows or Columns dialog box appears.
    • Complete the dialog box.
    • Click OK and Contribute adds the rows or columns to your table.

[top]

Deleting Table Rows and Columns

You can delete a single row or column, or you can delete multiple rows or columns at the same time. To delete rows or columns from a table, do one of the following:

  • Select entire rows or columns, and then press Delete or Backspace.
  • Select entire rows or columns or place the insertion point in a single row or column, right-click (Windows) or Control-click (Macintosh), and then select Delete Row or Delete Column.
  • Select entire rows or columns, and then select Table > Delete > Row or Table > Delete > Column.

[top]

Merging and Splitting Table Cells

You can merge any number of adjacent cells--as long as the entire selection is a line or a rectangle of cells--to produce a single cell that spans several columns or rows. You can split a cell into any number of rows or columns, regardless of whether it was previously merged.

  1. To Merge Table Cells

    • Select the cells you want to merge. (You must select at least two cells.)
    • Do one of the following:
      • Select Table > Merge Cells or Right-click (Windows)
      • Control-click (Macintosh), and then select Merge Cells.
    • Contribute merges the content into a single cell.
  2. To Split Table Cells

    • Place the insertion point in the cell you want to split. Note: Contribute only splits one cell at a time, even if you select multiple cells.
    • Do one of the following:
      • Select Table > Split Cell.
      • Right-click (Windows) or Control-click (Macintosh), and then select Split Cell.
    • The Split Cell dialog box appears.
    • Select a radio button to indicate whether to split the cell into rows or columns, and then enter the number of new rows or columns in which to divide the cell.
    • Click OK and Contribute splits the cell into multiple rows or columns.

[top]

Resizing Tables, Rows, and Columns

You can resize an entire table or individual rows and columns. When you resize an entire table, all the cells in the table are resized proportionately.

  1. Resize a Table

    Select the table you want to resize.

    • To resize the table horizontally, drag the selection handle on the right.

    • To resize the table vertically, drag the selection handle on the bottom.

    • To resize in both dimensions, drag the selection handle at the lower right corner.

  2. Resize a Column’s Width

    • Select the column, and then drag the right border of the column or select the column, and then click the Table button in the toolbar.

    • In the Table Column Properties dialog box, change the number in the Column width text box, and then select Pixels or Percent for the width. Alternatively, select Fit to contents to clear the set width and resize the columns to accommodate the content you add.

    • Note: If you select any column but the rightmost one, the width of the adjacent column also changes, and Contribute retains the original table width. If you select the rightmost column, the width of the entire table changes, and all the columns grow wider or narrower proportionately.

  3. Resize a Row’s Height

    • Select the row, and then drag the lower border of the row or select the row, and then click the Table button in the toolbar.

    • In the Table Row Properties dialog box, change the number in the Row height text box. Alternatively, select Fit to contents to clear the set height and resize the rows to accommodate the content you add.

[top]

Modifying Table Properties

You can modify the alignment, width, border width and color, and background color of a selected table.

  1. To Modify Table Properties

    • Select the table you want to modify.
    • Do one of the following to open the Table Properties dialog box:
      • Click the Table button in the toolbar.
      • Right-click (Windows) or Control-click (Macintosh), and then select Table Properties from the pop-up menu.
      • Select Table > Table Properties.
    • The Table Properties dialog box appears.
    • Change table properties as necessary.
    • Click Apply to apply changes without closing the dialog box, or click OK to apply changes and close the dialog box.
  2. To Modify Table Row or Column Properties

    • Select the row or column you want to modify.
    • Do one of the following to open the Table Properties dialog box:
      • Click the Table button in the toolbar.
      • Right-click (Windows) or Control-click (Macintosh), and then select Table Cell Properties from the pop-up menu.
      • Select Table > Table Cell Properties and the Table Properties dialog box appears with the appropriate tab selected.
    • Change the row or column properties as desired.
    • Click Apply to preview your changes, or click OK to apply changes and close the dialog box.
  3. To Modify Cell Properties

    You can modify horizontal and vertical alignment, background color, and text wrap for a selected cell.

    • Select the cell or cells you want to modify.
    • Do one of the following to open the Table Properties dialog box:
      • Right-click (Windows) or Control-click (Macintosh), and then select Table Cell Properties from the pop-up menu.
      • Select Table > Table Cell Properties.
      • Click the Table button in the toolbar.
      • Note: If you placed the insertion point in the cell instead of selecting the cell, this option opens the Insert Table dialog box instead of the Table Properties dialog box for cells.
    • The Table Properties dialog box appears with the appropriate tab selected.
    • Change the cell properties as desired.
    • Click Apply to preview your changes, or click OK to apply changes and close the Table Properties dialog box.

[top]

Create a New Page

The easiest way to create a new page that is consistent with the layout and design of your site is to first copy an existing page. Then you simply replace the content on the copied page with your new content.

  • Browse to the page you want to copy, and then click the New Page button in the toolbar or select File > New Page. The New Page dialog box opens.
  • In the Create new page for section, select Copy of Current Page. Note: If you cannot select this option, you are viewing a page in your browser that you cannot copy.
  • A preview of the page appears in the Preview pane on the right side of the dialog box.
  • Enter a page title in the Page title text box.
  • This title appears in the browser title bar when a website visitor views the page; it does not appear on the page itself.
  • Click OK.
  • The new page opens as a draft in Contribute.
  • After you create the page, don’t forget to link to it so visitors to your site can access it.
  • Note: Contribute creates the new page in the same folder as the page you copied. You can change the folder location when you publish the new page, if you need to.

[top]

Update Your Password

Note: your FTP password is synced with your SOM user ID. Since your SOM user ID changes every 90, so will your FTP password. To change your password select Edit > My Connections. The My Connections dialog box appears. Select your site from the list and select the Edit button. The Edit Connection Wizard dialog box appears. Select Next once to go to the second page. Type your new password under What is the FTP password?.

[top]

Known Issue: Contribute Uploads Multiple Copies of Documents

After updating a document, the changes do not show when published. This may happen when trying to update non-HTML pages, such as Microsoft Office documents or other file formats that Contribute cannot edit natively.

For instance, you determine that an existing Microsoft Word document on the web site needs to be updated. You update the file on the local computer and then, in Contribute, you re-link from the web page to the newly updated version of the document in order to re-publish that document. After the web page is published, however, clicking the link still brings up the old version of the Word document.

Reason

This will happen when a local copy of the file is changed, rather than a copy of the file on the server. Contribute will not overwrite a document if a file with the same name already exists on the server. Contribute will instead create a new file with the same name plus numeric suffix, such as 'filename_001.doc'.

Solution

To prevent Contribute from uploading new versions of the file, edit the live document on the server, not a copy on the local machine.

Use the following steps as a guide when publishing updated versions of a document:

  1. Browse to the document on the server using the Contribute browser. Click on the link that leads to the document.
  2. Once found, click the Edit button. The document will be downloaded from the server. The message "Editing Draft in Another Application" appears.
  3. Contribute launches the application that can be used to modify the document. In this example, Contribute cannot edit a Word doc, so Contribute will pass the file to Microsoft Word for editing. Make the necessary changes and save the document.
  4. In Contribute, click the Publish button. The updated version of the document will be uploaded and the link will point to the updated version.

[top]